EC-CUBE(ver2.11.5) インストール

KAGOYA Internet Routing は EC-CUBE のオフィシャルパートナーです。EC-CUBE を簡単にご利用開始いただけます。
EC-CUBE の簡単インストールでのインストール手順とご利用開始までの手順を説明いたします。
⇒ EC-CUBE について

はじめに

EC-CUBE(ver2.11.5) をインストールされる前に下記の事項をご確認ください。

  • インストールの前に PostgreSQL または MySQL いずれかのデータベースを作成してください。
    EC-CUBE は商品数が多い場合、MySQL より PostgreSQL を利用したほうが、サイトをスムーズに表示できるため、PostgreSQL の利用を推奨しています。

    ■ PostgreSQL(推奨)

    PostgretSQLデータベースの作成は、当社コントロールパネルで、以下の画面を開きます。

    ◇コントロールパネル > システム > データベース > PostgreSQL > DB追加

    データベースの作成方法に関しては、「PostgreSQLの利用」をご確認ください。
    • データベースを作成する際、文字コードは、UTF-8 を選択してください。

    ■ MySQL

    MySQLデータベースの作成は、当社コントロールパネルで、以下の画面を開きます。

    ◇コントロールパネル > システム > データベース > MySQL > DB追加

    データベースの作成方法に関しては、「MySQLの利用」をご確認ください。
    • データベースを作成する際、文字照合順序は、utf8_general_ci を選択してください。

  • 旧バージョン(ver2.4系またはそれ以前)には、クロスサイトリクエストフォージェリの脆弱性が存在します。
    旧バージョンをご利用中のお客様は、ver2.11系への移行をお早めにお済ませください。
    ■ 参考URL JVN#37878530 EC-CUBE におけるクロスサイトリクエストフォージェリの脆弱性
        http://jvn.jp/jp/JVN37878530/

  • ver2.4系からver2.11系への移行方法

    ver2.4系とver2.11系はデータ構造が大幅に異なるため、ver2.4系から上書きインストールでのアップグレードはできません。ver2.11系をver2.4系とは別に新規インストールしたうえで、以下のモジュールを利用することにより、ver2.4系からver2.11系に、スムーズにデータを移行できます。

    • データエクスポートモジュール(2.4系)
      対応バージョン:EC-CUBE2系(2.4)
      https://store.ec-cube.net/products/detail.php?product_id=180
      2.4系の顧客データ・商品データ・受注データを、1クリックで、2.11系に対応したCSV形式に出力できるモジュールです。

    • データインポートモジュール(2.11系)
      対応バージョン:EC-CUBE2系(2.11)
      https://store.ec-cube.net/products/detail.php?product_id=181
      「データエクスポートモジュール」よりダウンロードしたデータを、2クリックで、2.11系に移行できるモジュールです。

    • 上記モジュールは開発元の株式会社ロックオンより無償で提供されているものです。サポート窓口はございませんので、自己責任でご利用ください。
      ■ 参考URL 「EC-CUBE」2.4系から2.11系へのバージョンアップを容易にする「データ移行モジュール」を無償提供(2011/04/26)
          http://www.ec-cube.net/press/detail.php?press_id=114
    • 上記モジュールのダウンロードにはEC-CUBEオーナーズストアへの会員登録が必要です。
    • データエクスポートモジュールで画像データはエクスポートされません。商品登録などに画像データを使用している場合は、(/upload/)フォルダをダウンロードし、移行先の 2.11系の(/upload/)フォルダへ上書きして、手動でデータ移行してください。


  • 旧バージョン(ver2.4.3)の再インストール、ver2.3.4以降 から ver2.4.3 へのアップグレードをご希望の場合は、EC-CUBE(ver2.4.3) のインストール機能をご利用ください。
    ⇒ EC-CUBE(ver2.4.3) インストール